Pajek

From campisano.org
Jump to navigation Jump to search

Reduction of a Network

Local View

We can use partitions to reduce a network extracting one part, ex south-american countries

1 - load "Imports_manufactures.net"

2 - extract south-american countries

2.1 - load "Continent.clu"

2.2 - Operation -> Net. + Partitions -> Extract Subnetwork -> 6 (south-american cluster)

2.3 - note: the resulting subnetwork was selected on the first 'Networks' combobox

2.3 - note: you can show your subnetwork using Draw -> Draw

3 - draw economic clusters over south-american countries

3.1 - note, you need a subpartition of economic clusters with same dimension of your extracted partition

3.2 - load "World_system.clu" economical clusters

3.3 - select "World_system.clu" at first 'Partitions' combobox

3.4 - select "Continent.clu" at second 'Partitions' combobox

3.5 - Partitions -> Extract Subpartition (Second from First) -> 6 (south-american cluster)

3.6 - note: the resulting subpartition was selected on the first 'Partitions' combobox

3.7 - show your economic south-american partition using Draw -> Draw + First Partition


Global View

We can use partitions to reduce a network shrinking each class of vertices into one new vertex, ex continents

1 - load "Imports_manufactures.net"

2 - shrink all countries within a continent to a new vertex that represents the entire continent

2.1 - load "Continent.clu"

2.2 - Operation -> Net. + Partitions -> Shrink Network -> 1, 0 (1 is minimum lines to create lines, 0 indicate to shrink all classes)

2.3 - note: the resulting subnetwork was selected on the first 'Networks' combobox

2.4 - note: the resulting subpartition was selected on the first 'Partitions' combobox

2.5 - note: you can show your subnetwork using Draw -> Draw + First Partition

2.6 - note: you can set better names using File -> Partition -> Edit

2.7 - note: you can show relation's values using Options -> Lines -> Mark Lines -> with Values


Contextual View

We can use partial shrinking to shrink all class of vertices excelt the one in which there is a particularly interest, ex shrink all continents except the South American countries to see their relations with the other continents.

1 - load "Imports_manufactures.net"

2 - shrink all countries within a continent to a new vertex that represents the entire continent

2.1 - load "Continent.clu"

2.2 - Operation -> Net. + Partitions -> Shrink Network -> 1, 6 (1 is minimum lines to create lines, 6 indicate to not shrink south-american class)

2.3 - note: you can set better names using File -> Partition -> Edit

2.4 - note: you can show your subnetwork using Draw -> Draw + First Partition


References