Skype

From campisano.org
Jump to navigation Jump to search

NOTE: actual Skype version (2017 / 2018) does not store / import the old history

If this missing feature is unacceptable for you, you can still use the 4.3 version 'patching' it to authenticate as a most recent version. This is needed because in the login step, the server will recuse login of old Skype version. With the patch, Skype app 4.3 will lie, declaring itself as a most recent app.

The command to patch was obtained from the link How To Run Skype 4.3 for Linux After November 2017:

This command will patch the 'skype' binary file of version 4.3.9.37 to change its version to 8.3.0.37:

sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype


Skype (x64 5.3 version)

wget https://repo.skype.com/latest/skypeforlinux-64.deb
VER=`dpkg --info skypeforlinux-64.deb  | grep Version | sed -e 's| Version: ||g'`
DEST=/home/shared/opt/software/skype-${VER}
mkdir -p "${DEST}"
dpkg -x skypeforlinux-64.deb "${DEST}"
chown -R root:users "${DEST}"


Skype (x86 binary version 4.3) for Debian Jessie on i386 OS

apt-get install libc6 libstdc++6 libv4l-0:i386 libasound2 libpulse0 libxv1 libxss1 libqtdbus4 libqtwebkit4


Skype (x86 binary version 4.3) for Debian Jessie on amd64 OS

  • Dependencies:
apt-get install libc6:i386 libstdc++6:i386 libasound2:i386 libpulse0:i386 libqtwebkit4:i386 libxv1:i386 libxss1:i386


Run

  • If needed,
export LD_LIBRARY_PATH="/usr/lib/i386-linux-gnu:/usr/lib/i386-linux-gnu/libv4l:${LD_LIBRARY_PATH}";
export LD_PRELOAD_32="v4l1compat.so v4l2convert.so";
exec nice -1 "${SKYPE_PATH}"/skype;